Issue with the production server SSL certificate
Incident Report for Junico
Postmortem

Root cause

For some reason, EFF's Certbot was installed/active again (probably not removed correctly and then restored during a package upgrade process), so the Cloudflare certificates were replaced by Let's Encrypt ones. Those certificates expired after a short period and were not renewed automatically, so Cloudflare rejected the connection to the origin server.

Solution

Certbot now has been uninstalled completely and the correct certificate configuration was restored.

Posted Feb 28, 2021 - 09:37 CET

Resolved
This incident has been resolved.
Posted Feb 28, 2021 - 09:31 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 28, 2021 - 09:19 CET
Investigating
We're experiencing an issue with the production server SSL certificate and are currently looking into the issue.
Posted Feb 28, 2021 - 09:04 CET
This incident affected: Website.